Russian (RU)
Russian (RU)
English (UK)

Настройка главного меню

EasyKitchen

SketchUp

Начиная с версии 4.4, в EasyKitchen появилось Главное меню. Этот компонент отвечает за базовую настройку всех модулей библиотеки, помещаемых на рабочую область программы SketchUp. Каждый модуль имеет связь с главным меню и изменяет свои параметры в соответствии с теми, что указаны в Главном меню. Это значит, что настройка модулей "под себя" практически не требуется, за исключением мелких нюансов. Всё, что потребуется, это внести свои параметры в Главное меню и применить их!

    Это важно!

    Модули из библиотеки версии 4.4 и выше не будут работать без наличия компонента "Главного меню" в проекте.

    Установка Главного меню

    Первым делом нужно установить главное меню и закрепить его в программе. Для этого создайте новый проект через меню Файл->Новый (File->New). В окне компонентов найдите компонент "Главное меню" в папке EasyKitchen и вытащите его из библиотеки на рабочую область программы SketchUp. Поставить его можно куда угодно. Для удобства, чтобы не искать по всей области, мы поместили его в начало координат.

    Базовая настройка Главного меню

    Следующим шагом можно сделать базовую настройку Главного меню. Внесите в него свои параметры и примените их. После этого можно скрыть иконку Главного меню через слои (Теги), убрав галочку с одноимённого пункта. Не беспокойтесь, при желании вы всегда сможете вновь отобразить Главное меню и внести в него изменения.

    Также компонент Главного меню можно заблокировать, чтобы случайно не внести в него изменения вместе с другими элементами, если вы будете держать его видимым. Для этого кликнете по нему правой кнопкой мыши и выберите пункт Lock. Теперь с компонентом ничего не сделаешь, пока не разблокируешь его.

    Сохранение шаблона

    Когда завершите настройку, сохраните текущий проект как шаблон. Тогда уже настроенное Главное меню будет находится в каждом новом проекте по умолчанию. Для этого выберите пункт Файл->Сохранить как шаблон... (File->Save as Template...). Появится вот такое окно, в котором нужно придумать имя вашего шаблона:

    Осталось только нажать на кнопку сохранения и шаблон станет шаблоном рабочей области по умолчанию.

    Принципы работы

    Модули библиотеки EasyKitchen имеют множество связей с Главным меню. Это видно по парамерам любого модуля. Обратите внимание на звёздочки (*) которые есть почти у каждого пункта параметров. Это значит, что этот параметр имеет связь с Главным меню. Изменение такого параметра приведёт к потере связи с соответсвующим параметром главного меню. Но в этом нет ничего страшного. Так достигается высокая гибкость библиотеки. Вы в любой момент можете настроить любой модуль, вне зависимости от того, что указано в Главном меню. Но чтобы восстановить связи, понадобится новый модуль из библиотеки.

    Стоит также помнить, что параметры, указанные в Главном меню, будут применены к модулю не сразу.


    Есть 4 случая, когда эти параметры применяются:

    1. Модуль был изменён при помощи любого параметра или инструментом "Масштаб";
    2. Пользователь вручную кликнул по кнопке обновления компонента;
    3. Пользователь перерисовал динамический компонент через ПКМ;
    4. Плагин отчёта перерисовывает все модули перед формированием отчёта.

    В большинстве случаев модули претерпевают изменения практически сразу после помещения на рабочую область. Мы меняем их габаритные размеры и другие параметры, подгоняя под особенности проекта. Поэтому модули почти всегда сразу связыватся с Главным меню и берут из него данные.

    Но, бывают случаи, когда модуль не нужно видоизменять. Тогда достаточно кликнуть по динамической кнопке "Перерисовать", которая есть у каждого модуля. Тогда модуль сразу применит на себя параметры, указанные в Главном меню.

    И, наконец, при генерации отчёта, плагин предварительно обновляет все модули. Так исключаются возможные ошибки, связанные с неприменением параметров Главного меню.

    Поделитесь с друзьями:

    Оцените статью:

    Рейтинг 5 (5 Голоса)
    6 Комментарии

    Подскажите пожалуйста. Раньше при выборе любого компонента сцены, меню Component Options подтягивался автоматом к выбранной детали, теперь при смене детали надо закрывать каждый раз меню Component Options и снова клацать по иконке. Может я что-то сделал не так при переходе на 4.4?

    Ответить Поделиться

    Добрый день! Если вы имеете ввиду, что содержание окна параметров не изменяется в зависимости от выбранной детали, то такой глюк иногда случается с динамическими компонентами. Обычно помогает перезапуск программы SketchUp. Если не помогло - то понадобится переустановка. Если вы имеете ввиду что-то другое - то напишите нам в техподдержку, пожалуйста, приложив видео или скриншоты.

    Ответить Поделиться

    Подскажите пожалуйста как "перерисовать" назначить на горячую клавишу.

    Ответить Поделиться

    Добрый день! Выделите какой-нибудь компонент мышью, затем перейдите в меню программы SketchUp: Window->Preferences->Shortcuts и в поиске напишите Redraw. Появившийся в результате поиска пункт назначьте на какую-нибудь клавишу (или сочетание клавиш). У меня например на F5 подвязано.

    Ответить Поделиться

    Поменяла высоту ножек через главное меню с 100 на 120, но общая высота модулей не поменялась, то есть нижние модули из библиотеки добавляются с высотой корпуса 700 мм. Как это победить?

    Ответить Поделиться

    Добрый день! Параметры заданные в Главном меню применяются к модулям не сразу, а только после какого-нибудь изменения в них. Например, если изменить размер. Но удобнее всё-же воспользоваться кнопкой перерисовки (круговые стрелки). Нажав на неё динамическим кликом, вы сразу же внесёте изменения в модуль, в соответствии с настройками, заданными в Главном меню.
    А чтобы модули доставались уже готовыми из библиотеки, то нужно задать настройки в Главном меню, затем достать модуль, перерисовать его, кликнув по кнопке, и сохранить обратно в библиотеку.
    Если вдруг вы видите, что габаритный размер модуля меняется, а сам модуль нет - это значит, что в сцене либо нет Главного меню, либо оно старой версии.

    Ответить Поделиться